Cisco Nexus 3064-X Switch




To show the running-config:

# show running-config

!Command: show running-config
!Time: Tue Oct 31 20:55:00 2017

version 6.0(2)U2(9Z)
hostname ConfigNotes-10gSw

no feature telnet
feature lldp
feature vtp
...
vrf context management
  ip route 0.0.0.0/0 10.0.0.1
vlan 1
vlan 100
  name Accounting
spanning-tree vlan 1 priority 0

interface Ethernet1/1
  switchport access vlan 100

interface Ethernet1/2
  switchport access vlan 100
...
Cisco 3064-X

 

Creating a VLAN:

switch# configure terminal 
switch(config)# vlan 100
switch(config-vlan)# name Engineering

 

Adding interfaces to a VLAN:

switch# configure terminal
switch(config)# interface ethernet 1/1-20
switch(config-if)# switchport access vlan 100

 

Trunking the uplink Ports:

switch# configure terminal 
switch(config)# interface ethernet 1/52/1-4
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk native vlan 100
switch(config-if)# switchport trunk allow vlan all

Cisco 3064-X have four QSFP 40-Gb ports, you can use these ports to connect the switches. Trunk these ports for VTP to work. For 40-Gigabit Copper connections, use a QSFP Direct Attach Copper, Link to Amazon:

 

Configuring Native 802.1Q VLANs:

switch# configure terminal
switch(config)# vlan dot1q tag native 
switch(config)# show vlan dot1Q tag native
vlan dot1q native tag is enabled

 

Configuring Spanning Tree:

switch(config)# spanning-tree mode rapid-pvst
switch(config)# spanning-tree vlan 1,100 priority 4096
switch(config)# sh spanning-tree

 

Configuring VTP:

switch# configure terminal
switch(config)# feature vtp
switch(config)# vtp domain ConfigNotes
switch(config)# vtp version 2
switch(config)# show vtp status

 

Configuring MTU to Jumbo Frame:

switch(config)# policy-map type network-qos jumbo
switch(config-pmap-nq)# class type network-qos class-default
switch(config-pmap-nq-c)# mtu 9216
switch(config-pmap-nq-c)# exit
switch(config-pmap-nq)# exit
switch(config)# system qos
switch(config-sys-qos)# service-policy type network-qos jumbo
switch(config-sys-qos)# exit

 

Saving the Running Config:

switch(config)# copy running-config startup-config

 

To change the user password:

Switch(config)# username admin password YourNewPassword

 

The 3064 supports breakout, however, the QSFP ports can not be broken out independently. You must break them all out to 10GB or configure them all in 40 GB. This is done by setting the hardware profile mode:

# hardware profile portmode ?
  16x10g+12x40g  16x10G+12x40G port mode
  16x40g         16x40G port mode
  32x10g+8x40g   32x10G+8x40G port mode
  48x10g+4x40g   48x10G+4x40G port mode
  64x10g         64x10G port mode
  8x10g+14x40g   8x10g+14x40G port mode

Note that even though the command help gives the option to breakout the ports individually, this won’t actually work. The options that work are 48x10g+4x40g or 64x10g.

The switch must be reloaded for the change to take effect.



Published by

Ferdy Mañago

Portland, Oregon